OpenSSL < 0.9.6m / 0.9.7d Denial of Service

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote server is vulnerable to a denial of service attack.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.6m or 0.9.7d.

A remote attacker can crash the server by sending an overly long
Kerberos ticket.

See also :

http://www.us-cert.gov/cas/techalerts/TA04-078A.html
http://www.openssl.org/news/secadv_20040317.txt
http://marc.info/?l=bugtraq&m=107953412903636&w=2

Solution :

Upgrade to OpenSSL 0.9.6m / 0.9.7d or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 17750 ()

Bugtraq ID: 9899

CVE ID: CVE-2004-0112