This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.
The remote Apache Tomcat service is affected by multiple
According to its self-reported version number, the instance of Apache
Tomcat 4.x listening on the remote host is earlier than 4.1.36 and is
affected by the following vulnerabilities:
- Requests containing multiple 'content-length' headers
are not rejected as invalid. This error can allow
web-cache poisoning, cross-site scripting attacks and
information disclosure. (CVE-2005-2090)
- An input sanitization error exists that can allow
disclosure of sensitive information via directory
traversal. This vulnerability is exposed when the
server is configured to use the 'Proxy' module.
- 'Accept-Language' headers are not validated properly,
which can allow cross-site scripting attacks.
Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page so this may be
a false positive.
See also :
Update to Apache Tomcat version 4.1.36 or later.
Risk factor :
Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.1
Public Exploit Available : true