MySQL 4.1 < 4.1.3 Multiple Vulnerabilities

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.

Synopsis :

The remote database service is affected by multiple vulnerabilities.

Description :

The version of MySQL 4.1 installed on the remote host is earlier than
4.1.3. Such versions are reported affected by multiple
vulnerabilities :

- It is possible for a remote attacker to bypass the
password authentication mechanism using a specially
crafted packet with a zero-length scramble buff
string. (CVE-2004-0627)

- The server fails to check the length of a scrambled
password used by the 4.1 authentication protocol and
sent as part of a client authentication packet, which
can result in a stack-based buffer overflow.

See also :

Solution :

Upgrade to MySQL 4.1.3 or later.

Risk factor :

High / CVSS Base Score : 7.5
CVSS Temporal Score : 6.2
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 17691 ()

Bugtraq ID: 10654

CVE ID: CVE-2004-0627