GLSA-200504-02 : Sylpheed, Sylpheed-claws: Buffer overflow on message display

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200504-02
(Sylpheed, Sylpheed-claws: Buffer overflow on message display)

Sylpheed and Sylpheed-claws fail to properly handle messages
containing attachments with MIME-encoded filenames.

Impact :

An attacker can send a malicious email message which, when
displayed, would cause the program to crash, potentially allowing the
execution of arbitrary code with the privileges of the user running the
software.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?19b9ac9e
http://www.gentoo.org/security/en/glsa/glsa-200504-02.xml

Solution :

All Sylpheed users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=mail-client/sylpheed-1.0.4'
All Sylpheed-claws users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=mail-client/sylpheed-claws-1.0.4'

Risk factor :

Medium

Family: Gentoo Local Security Checks

Nessus Plugin ID: 17676 (gentoo_GLSA-200504-02.nasl)

Bugtraq ID:

CVE ID: