GLSA-200504-01 : telnet-bsd: Multiple buffer overflows

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200504-01
(telnet-bsd: Multiple buffer overflows)

A buffer overflow has been identified in the env_opt_add()
function of telnet-bsd, where a response requiring excessive escaping
can cause a heap-based buffer overflow. Another issue has been
identified in the slc_add_reply() function, where a large number of SLC
commands can overflow a fixed size buffer.

Impact :

Successful exploitation would require a vulnerable user to connect
to an attacker-controlled host using telnet, potentially executing
arbitrary code with the permissions of the telnet user.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?0f2f4fd7
http://www.nessus.org/u?69f65c02
http://www.gentoo.org/security/en/glsa/glsa-200504-01.xml

Solution :

All telnet-bsd users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-misc/telnet-bsd-1.0-r1'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 17675 (gentoo_GLSA-200504-01.nasl)

Bugtraq ID:

CVE ID: CVE-2005-0468
CVE-2005-0469