GLSA-200503-35 : Smarty: Template vulnerability

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200503-35
(Smarty: Template vulnerability)

A vulnerability has been discovered within the regex_replace modifier
of the Smarty templates when allowing access to untrusted users.
Furthermore, it was possible to call functions from {if} statements and
{math} functions.

Impact :

These issues may allow a remote attacker to bypass the 'template
security' feature of Smarty, and execute arbitrary PHP code.

Workaround :

Do not grant template access to untrusted users.

See also :

http://www.nessus.org/u?b3cc0ecf
http://www.gentoo.org/security/en/glsa/glsa-200503-35.xml

Solution :

All Smarty users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev-php/smarty-2.6.9'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 17665 (gentoo_GLSA-200503-35.nasl)

Bugtraq ID:

CVE ID: CVE-2005-0913