Smail-3 < 3.2.0.121 Multiple Vulnerabilities

This script is Copyright (C) 2005-2016 Tenable Network Security, Inc.


Synopsis :

The remote mail server is affected by multiple vulnerabilities.

Description :

According to its banner, the remote host is running as its mail server
S-mail version 3.2.0.120 or older. Such versions contain various
vulnerabilities that may allow an unauthenticated attacker execute
arbitrary code on the remote host by exploiting a heap overflow by
sending a malformed argument to the 'MAIL FROM' command.

See also :

http://seclists.org/bugtraq/2005/Mar/447
http://seclists.org/bugtraq/2005/Mar/471
http://seclists.org/bugtraq/2005/Mar/474
http://seclists.org/bugtraq/2005/Mar/486
ftp://ftp.weird.com/pub/local/smail-3.2.0.121.ChangeLog

Solution :

Upgrade to Smail 3.2.0.121 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: SMTP problems

Nessus Plugin ID: 17633 ()

Bugtraq ID: 12899
12922

CVE ID: CVE-2005-0892
CVE-2005-0893

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now