LSH lshd parse_kexinit() Function Malformed Key Exchange Message Remote DoS

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote SSH server is affected by a denial of service
vulnerability.

Description :

The remote host is running Lysator's LSH, a version of Secure Shell
(SSH) that is available for Unix-like platforms. This version of LSH
is reportedly vulnerable to a denial of service attack.

An attacker can exploit this issue by sending a malformed key exchange
message.

See also :

http://lists.lysator.liu.se/pipermail/lsh-bugs/2005q1/000328.html

Solution :

Upgrade to LSH 2.0.1 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Denial of Service

Nessus Plugin ID: 17352 (lsh_dos.nasl)

Bugtraq ID: 12829

CVE ID: CVE-2005-0814