Jetty < 4.2.19 HTTP Server Content-Length Handling Remote Overflow DoS

This script is Copyright (C) 2005-2011 Westpoint Limited

Synopsis :

The remote web server is prone to a denial of service attack.

Description :

According to its banner, the remote host is running a version of Jetty
that is older than 4.2.19. The version is vulnerable to a unspecified
denial of service.

See also :

Solution :

Upgrade to version 4.2.19 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 17348 (jetty_4_1_9_dos.nasl)

Bugtraq ID: 9917

CVE ID: CVE-2004-2381