GLSA-200502-31 : uim: Privilege escalation vulnerability

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200502-31
(uim: Privilege escalation vulnerability)

Takumi Asaki discovered that uim insufficiently checks environment
variables. setuid/setgid applications linked against libuim could end
up executing arbitrary code. This vulnerability only affects
immodule-enabled Qt (if you build Qt 3.3.2 or later versions with
USE='immqt' or USE='immqt-bc').

Impact :

A malicious local user could exploit this vulnerability to execute
arbitrary code with escalated privileges.

Workaround :

There is no known workaround at this time.

See also :

http://lists.freedesktop.org/archives/uim/2005-February/000996.html
http://www.gentoo.org/security/en/glsa/glsa-200502-31.xml

Solution :

All uim users should upgrade to the latest available version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-i18n/uim-0.4.5.1'

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 17234 (gentoo_GLSA-200502-31.nasl)

Bugtraq ID:

CVE ID: CVE-2005-0503