RHEL 4 : postgresql (RHSA-2005:138)

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated postresql packages that correct various security issues are
now available for Red Hat Enterprise Linux 4.

This update has been rated as having important security impact by the
Red Hat Security Response Team.

A flaw in the LOAD command in PostgreSQL was discovered. A local user
could use this flaw to load arbitrary shared libraries and therefore
execute arbitrary code, gaining the privileges of the PostgreSQL
server. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CVE-2005-0227 to this issue.

A permission checking flaw in PostgreSQL was discovered. A local user
could bypass the EXECUTE permission check for functions by using the
CREATE AGGREGATE command. The Common Vulnerabilities and Exposures
project (cve.mitre.org) has assigned the name CVE-2005-0244 to this
issue.

Multiple buffer overflows were found in PL/PgSQL. A database user who
has permissions to create plpgsql functions could trigger this flaw
which could lead to arbitrary code execution, gaining the privileges
of the PostgreSQL server. The Common Vulnerabilities and Exposures
project (cve.mitre.org) has assigned the names CVE-2005-0245 and
CVE-2005-0247 to these issues.

A flaw in the integer aggregator (intagg) contrib module for
PostgreSQL was found. A user could create carefully crafted arrays and
cause a denial of service (crash). The Common Vulnerabilities and
Exposures project (cve.mitre.org) has assigned the name CVE-2005-0246
to this issue.

The update also fixes some minor problems, notably conflicts with
SELinux.

Users of postgresql should update to these erratum packages that
contain patches and are not vulnerable to these issues.

See also :

https://www.redhat.com/security/data/cve/CVE-2005-0227.html
https://www.redhat.com/security/data/cve/CVE-2005-0244.html
https://www.redhat.com/security/data/cve/CVE-2005-0245.html
https://www.redhat.com/security/data/cve/CVE-2005-0246.html
https://www.redhat.com/security/data/cve/CVE-2005-0247.html
http://rhn.redhat.com/errata/RHSA-2005-138.html

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 17192 ()

Bugtraq ID:

CVE ID: CVE-2005-0227
CVE-2005-0244
CVE-2005-0245
CVE-2005-0246
CVE-2005-0247