RHEL 4 : alsa-lib (RHSA-2005:033)

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

An updated alsa-lib package that fixes a flaw that disabled stack
execution protection is now available for Red Hat Enterprise Linux 4.

This update has been rated as having important security impact by the
Red Hat Security Response Team.

The alsa-lib package provides a library of functions for communication
with kernel sound drivers.

A flaw in the alsa mixer code was discovered that caused stack
execution protection to be disabled for the libasound.so library. The
effect of this flaw is that stack execution protection, through NX or
Exec-Shield, would be disabled for any application linked to
libasound. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CVE-2005-0087 to this issue

Users are advised to upgrade to this updated package, which contains a
patched version of the library which correctly enables stack execution
protection.

See also :

https://www.redhat.com/security/data/cve/CVE-2005-0087.html
http://rhn.redhat.com/errata/RHSA-2005-033.html

Solution :

Update the affected alsa-lib and / or alsa-lib-devel packages.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 17167 ()

Bugtraq ID:

CVE ID: CVE-2005-0087