RHEL 2.1 / 3 : vim (RHSA-2005:122)

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated vim packages that fix a security vulnerability are now
available.

This update has been rated as having low security impact by the Red
Hat Security Response Team.

VIM (Vi IMproved) is an updated and improved version of the vi
screen-based editor.

The Debian Security Audit Project discovered an insecure temporary
file usage in VIM. A local user could overwrite or create files as a
different user who happens to run one of the the vulnerable utilities.
The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CVE-2005-0069 to this issue.

All users of VIM are advised to upgrade to these erratum packages,
which contain a backported patche for this issue.

See also :

https://www.redhat.com/security/data/cve/CVE-2005-0069.html
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=289560
http://rhn.redhat.com/errata/RHSA-2005-122.html

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 17148 ()

Bugtraq ID:

CVE ID: CVE-2005-0069