lighttpd < 1.3.8 Null Byte Request CGI Script Source Code Disclosure

This script is Copyright (C) 2005-2016 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by an information disclosure
vulnerability.

Description :

According to its banner, the version of lighttpd running on the remote
host is prior to 1.3.8. It is, therefore, affected by an information
disclosure vulnerability. An unauthenticated, remote attacker can
exploit this vulnerability, by requesting a CGI script that is
appended by a '%00', to read the source of the script.

Note that Nessus has not tested for this issue but has instead relied
only on the application's self-reported version number.

See also :

http://article.gmane.org/gmane.comp.web.lighttpd/1171

Solution :

Upgrade to lighttpd version 1.3.8 or later

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.3
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 16475 (lighttpd_cgi.nasl)

Bugtraq ID: 12567

CVE ID: CVE-2005-0453