GLSA-200502-06 : LessTif: Multiple vulnerabilities in libXpm

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200502-06
(LessTif: Multiple vulnerabilities in libXpm)

Multiple vulnerabilities, including buffer overflows, out of
bounds memory access and directory traversals, have been discovered in
libXpm, which is shipped as a part of the X Window System. LessTif, an
application that includes libXpm, suffers from the same issues.

Impact :

A carefully-crafted XPM file could crash applications making use
of the LessTif toolkit, potentially allowing the execution of arbitrary
code with the privileges of the user running the application.

Workaround :

There is no known workaround at this time.

See also :

http://www.lesstif.org/ReleaseNotes.html
http://www.gentoo.org/security/en/glsa/glsa-200502-06.xml

Solution :

All LessTif users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=x11-libs/lesstif-0.94.0'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 16443 (gentoo_GLSA-200502-06.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0914