GLSA-200501-12 : TikiWiki: Arbitrary command execution

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200501-12
(TikiWiki: Arbitrary command execution)

TikiWiki lacks a check on uploaded images in the Wiki edit page.

Impact :

A malicious user could run arbitrary commands on the server by
uploading and calling a PHP script.

Workaround :

There is no known workaround at this time.

See also :

http://tikiwiki.org/tiki-read_article.php?articleId=97
http://www.gentoo.org/security/en/glsa/glsa-200501-12.xml

Solution :

All TikiWiki users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/tikiwiki-1.8.4.1'
Note: Users with the vhosts USE flag set should manually use
webapp-config to finalize the update.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 16403 (gentoo_GLSA-200501-12.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1386