GLSA-200501-08 : phpGroupWare: Various vulnerabilities

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200501-08
(phpGroupWare: Various vulnerabilities)

Several flaws were discovered in phpGroupWare making it vulnerable to
cross-site scripting attacks, SQL injection, and full path disclosure.

Impact :

These vulnerabilities could allow an attacker to perform cross-site
scripting attacks, execute SQL queries, and disclose the full path of
the web directory.

Workaround :

There is no known workaround at this time.

See also :

http://www.securityfocus.com/archive/1/384492
http://www.gentoo.org/security/en/glsa/glsa-200501-08.xml

Solution :

All phpGroupWare users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/phpgroupware-0.9.16.004'
Note: Users with the vhosts USE flag set should manually use
webapp-config to finalize the update.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 16399 (gentoo_GLSA-200501-08.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1383
CVE-2004-1384
CVE-2004-1385