ht://Dig htsearch.cgi config Parameter XSS

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web search engine that is affected by a
cross-site scripting vulnerability.

Description :

The remote host is running a version of ht://Dig which is vulnerable
to an unspecified cross-site scripting attack. An attacker can exploit
this flaw to steal information from unsuspecting users.

See also :

http://www.nessus.org/u?569e3511
http://www.nessus.org/u?a7899e11
ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2005.45/SCOSA-2005.45.txt

Solution :

Upgrade to ht://Dig 3.2.0b7 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 16317 (htdig_xss2.nasl)

Bugtraq ID: 12442

CVE ID: CVE-2005-0085