PostgreSQL < 7.2.7 / 7.3.9 / 7.4.7 / 8.0.1 Multiple Vulnerabilities

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

It may be possible to run arbitrary commands on the remote server.

Description :

The remote PostgreSQL server, according to its version number, is
vulnerable to multiple flaws that could allow an attacker who has the
rights to query the remote database to obtain a shell on this host.

Solution :

Upgrade to postgresql 7.2.7, 7.3.9, 7.4.7, 8.0.1 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 4.8
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 16309 ()

Bugtraq ID: 12417
12411

CVE ID: CVE-2005-0227
CVE-2005-0244
CVE-2005-0245
CVE-2005-0246
CVE-2005-0247