Squid < 2.5.STABLE8 Multiple Vulnerabilities

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is affected by multiple vulnerabilities.

Description :

According to its version number, the remote Squid caching proxy is
affected by several security flaws :

- There is a buffer overflow when handling the reply of a
rogue gopher site. (CVE-2005-0094)

- There is a denial of service vulnerability in the WCCP
code of the remote proxy. (CVE-2005-0095)

- There is a buffer overflow in the WCCP code that may
allow an attacker to execute arbitrary code on the
remote host. (CVE-2005-0211)

- There is a flaw in the 'squid_ldap_auth' module that may
allow an attacker to bypass authentication and to gain
access to the remote proxy. (CVE-2005-0173)

- There is a flaw in the way Squid parses HTTP reply
headers. (CVE-2005-0241)

- There is a weakness that may allow for cache poisoning
via
HTTP response splitting. (CVE-2005-0175)

- There is a weakness that may allow for cache poisoning
via
crafted malformed headers. (CVE-2005-0174)

Note that this may be a false-positive given the way the Squid team
handles releases. Make sure that all the appropriate patches have been
applied.

See also :

http://www.squid-cache.org/Versions/v2/2.5/bugs/

Solution :

Upgrade to Squid 2.5.STABLE8 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false