GLSA-200412-18 : abcm2ps: Buffer overflow vulnerability

This script is Copyright (C) 2004-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200412-18
(abcm2ps: Buffer overflow vulnerability)

Limin Wang has located a buffer overflow inside the put_words()
function in the abcm2ps code.

Impact :

A remote attacker could convince the victim to download a
specially crafted ABC file. Upon execution, this file would trigger the
buffer overflow and lead to the execution of arbitrary code with the
permissions of the user running abcm2ps.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All abcm2ps users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-sound/abcm2ps-3.7.21'

Risk factor :


Family: Gentoo Local Security Checks

Nessus Plugin ID: 16005 (gentoo_GLSA-200412-18.nasl)

Bugtraq ID: