RHEL 2.1 : kernel (RHSA-2004:505)

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated kernel packages are now available as part of ongoing support
and maintenance of Red Hat Enterprise Linux version 2.1. This is the
sixth regular update.

The Linux kernel handles the basic functions of the operating system.

This is the sixth regular kernel update to Red Hat Enterprise Linux
version 2.1. It updates a number of device drivers, and adds much
improved SATA support.

This update includes fixes for several security issues :

Paul Starzetz of iSEC discovered various flaws in the ELF binary
loader affecting kernels prior to 2.4.28. A local user could use these
flaws to gain read access to executable-only binaries or possibly gain
privileges. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the names CVE-2004-1070, CVE-2004-1071,
CVE-2004-1072, and CVE-2004-1073 to these issues.

A missing serialization flaw in unix_dgram_recvmsg was discovered that
affects kernels prior to 2.4.28. A local user could potentially make
use of a race condition in order to gain privileges. (CVE-2004-1068)

Stefan Esser discovered various flaws including buffer overflows in
the smbfs driver affecting kernels before 2.4.28. A local user may be
able to cause a denial of service (crash) or possibly gain privileges.
In order to exploit these flaws the user would need to have control of
a connected smb server. (CVE-2004-0883, CVE-2004-0949)

Conectiva discovered flaws in certain USB drivers affecting kernels
before 2.4.27 which used the copy_to_user function on uninitialized
structures. These flaws could allow local users to read small amounts
of kernel memory. (CVE-2004-0685)

The ext3 code in kernels before 2.4.26 did not properly initialize
journal descriptor blocks. A privileged local user could read portions
of kernel memory. (CVE-2004-0177)

The following drivers have also been updated :

* tg3 v3.10 * e1000 v5.3.19-k2 * e100 v3.0.27-k2 * megaraid *
megaraid2 v2.10.8.2

All Red Hat Enterprise Linux 2.1 users are advised to upgrade their
kernels to the packages associated with their machine architectures
and configurations as listed in this erratum.

See also :

https://www.redhat.com/security/data/cve/CVE-2004-0177.html
https://www.redhat.com/security/data/cve/CVE-2004-0685.html
https://www.redhat.com/security/data/cve/CVE-2004-0883.html
https://www.redhat.com/security/data/cve/CVE-2004-0949.html
https://www.redhat.com/security/data/cve/CVE-2004-1068.html
https://www.redhat.com/security/data/cve/CVE-2004-1070.html
https://www.redhat.com/security/data/cve/CVE-2004-1071.html
https://www.redhat.com/security/data/cve/CVE-2004-1072.html
https://www.redhat.com/security/data/cve/CVE-2004-1073.html
http://rhn.redhat.com/errata/RHSA-2004-505.html

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 15958 ()

Bugtraq ID:

CVE ID: CVE-2004-0136
CVE-2004-0177
CVE-2004-0685
CVE-2004-0883
CVE-2004-0949
CVE-2004-1068
CVE-2004-1070
CVE-2004-1071
CVE-2004-1072
CVE-2004-1073