PunBB < 1.1.2 install.php XSS

This script is Copyright (C) 2004-2011 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a PHP application that is affected by
several cross-site scripting vulnerabilities.

Description :

The remote version of PunBB is vulnerable to cross-site scripting
flaws through 'install.php' script. With a specially crafted URL, an
attacker can inject arbitrary HTML and script code into a user's
browser resulting in the possible theft of authentication cookies,
mis-representation of site contents, and the like.

See also :

http://www.punbb.org/changelogs/1.1.1_to_1.1.2.txt

Solution :

Update to PunBB version 1.1.2 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 15939 ()

Bugtraq ID: 11845

CVE ID: