GLSA-200411-32 : phpBB: Remote command execution

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200411-32
(phpBB: Remote command execution)

phpBB contains a vulnerability in the highlighting code and several
vulnerabilities in the username handling code.

Impact :

An attacker can exploit the highlighting vulnerability to access the
PHP exec() function without restriction, allowing them to run arbitrary
commands with the rights of the web server user (for example the apache
user). Furthermore, the username handling vulnerability might be abused
to execute SQL statements on the phpBB database.

See also :

http://www.phpbb.com/phpBB/viewtopic.php?t=240513
http://www.gentoo.org/security/en/glsa/glsa-200411-32.xml

Solution :

All phpBB users should upgrade to the latest version to fix all known
vulnerabilities:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/phpbb-2.0.11'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 15826 (gentoo_GLSA-200411-32.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1315