GLSA-200411-24 : BNC: Buffer overflow vulnerability

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200411-24
(BNC: Buffer overflow vulnerability)

Leon Juranic discovered that BNC fails to do proper bounds
checking when checking server response.

Impact :

An attacker could exploit this to cause a Denial of Service and
potentially execute arbitary code with the permissions of the user
running BNC.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?7e9d3c1f
http://www.nessus.org/u?388d13fb
http://www.gentoo.org/security/en/glsa/glsa-200411-24.xml

Solution :

All BNC users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-irc/bnc-2.9.1'

Risk factor :

High

Family: Gentoo Local Security Checks

Nessus Plugin ID: 15725 (gentoo_GLSA-200411-24.nasl)

Bugtraq ID:

CVE ID: