GLSA-200411-20 : ez-ipupdate: Format string vulnerability

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200411-20
(ez-ipupdate: Format string vulnerability)

Ulf Harnhammar from the Debian Security Audit Project discovered a format string vulnerability in ez-ipupdate.

Impact :

An attacker could exploit this to execute arbitrary code with the permissions of the user running ez-ipupdate, which could be the root user.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?e8e20c92
http://www.gentoo.org/security/en/glsa/glsa-200411-20.xml

Solution :

All ez-ipupdate users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-dns/ez-ipupdate-3.0.11_beta8-r1'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 15695 (gentoo_GLSA-200411-20.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0980