GLSA-200411-14 : Kaffeine, gxine: Remotely exploitable buffer overflow

This script is Copyright (C) 2004-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200411-14
(Kaffeine, gxine: Remotely exploitable buffer overflow)

KF of Secure Network Operations has discovered an overflow that occurs
during the Content-Type header processing of Kaffeine. The vulnerable
code in Kaffeine is reused from gxine, making gxine vulnerable as well.

Impact :

An attacker could create a specially crafted Content-type header from a
malicious HTTP server, and crash a user's instance of Kaffeine or
gxine, potentially allowing the execution of arbitrary code.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All Kaffeine users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-video/kaffeine-0.4.3b-r1'
All gxine users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-video/gxine-0.3.3-r1'

Risk factor :

Critical / CVSS Base Score : 10.0

Family: Gentoo Local Security Checks

Nessus Plugin ID: 15648 (gentoo_GLSA-200411-14.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1034