Cherokee Web Server Error Page XSS

This script is Copyright (C) 2004-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server is vulnerable to a cross-site scripting issue.

Description :

The remote host is running Cherokee - a fast and tiny web server.

The remote version of this software is vulnerable to cross-site
scripting attacks due to lack of sanitization in returned error pages.

See also :

Solution :

Upgrade to Cherokee 0.4.8 or newer.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 15618 (cherokee_0_4_7.nasl)

Bugtraq ID: 9496

CVE ID: CVE-2004-2171