[GLSA-200411-01] ppp: Remote denial of service vulnerability

This script is Copyright (C) 2004-2010 Tenable Network Security, Inc.


Synopsis :

The remote host is missing the GLSA-200411-01 security update.

Description :

The remote host is affected by the vulnerability described in
GLSA-200411-01 (ppp: Remote denial of service vulnerability)

The pppd server improperly verifies header fields, making it vulnerable to
denial of service attacks.

Impact

An attacker can cause the pppd server to access memory that it isn't
allowed to, causing the server to crash. No code execution is possible with
this vulnerability, because no data is getting copied.

Workaround

There is no known workaround at this time.

See also :

http://www.securityfocus.com/archive/1/379450
http://www.gentoo.org/security/en/glsa/glsa-200411-01.xml

Solution :

All ppp users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-dialup/ppp-2.4.2-r7"

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 15589 (gentoo_GLSA-200411-01.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1002