GLSA-200410-27 : mpg123: Buffer overflow vulnerabilities

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200410-27
(mpg123: Buffer overflow vulnerabilities)

Buffer overflow vulnerabilities in the getauthfromURL() and http_open()
functions have been reported by Carlos Barros. Additionally, the Gentoo
Linux Sound Team fixed additional boundary checks which were found to
be lacking.

Impact :

By enticing a user to open a malicious playlist or URL or making use of
a specially crafted symlink, an attacker could possibly execute
arbitrary code with the rights of the user running mpg123.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?baa56ffe
http://www.gentoo.org/security/en/glsa/glsa-200410-27.xml

Solution :

All mpg123 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-sound/mpg123-0.59s-r5'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 15579 (gentoo_GLSA-200410-27.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0982