Apache mod_proxy Content-Length Overflow

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by a heap-based buffer overflow
vulnerability.

Description :

The remote web server appears to be running a version of Apache that
is older than version 1.3.32.

This version is reportedly vulnerable to a heap-based buffer overflow
in proxy_util.c for mod_proxy. This issue may lead remote attackers to
cause a denial of service and possibly execute arbitrary code on the
server.

See also :

http://archives.neohapsis.com/archives/fulldisclosure/2004-06/0276.html
http://archives.neohapsis.com/archives/fulldisclosure/2004-06/0279.html

Solution :

Upgrade to Apache 1.3.32 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 15555 (apache_mod_proxy_buff_overflow.nasl)

Bugtraq ID: 10508

CVE ID: CVE-2004-0492