IBM DB2 < 8 Fix Pack 7a Multiple Vulnerabilities

This script is Copyright (C) 2004-2016 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The remote host is running a vulnerable version of IBM DB2.

There are multiple remote buffer overflow vulnerabilities in this
version that could allow an attacker to cause a denial of service, or
possibly execute arbitrary code.

See also :

http://www.ngssoftware.com/advisories/db223122004K.txt
http://seclists.org/vulnwatch/2004/q3/36
http://seclists.org/bugtraq/2004/Dec/353
http://seclists.org/bugtraq/2005/Jan/28
http://seclists.org/bugtraq/2005/Jan/31
http://seclists.org/bugtraq/2005/Jan/32
http://seclists.org/bugtraq/2005/Jan/33
http://seclists.org/bugtraq/2005/Jan/34
http://seclists.org/bugtraq/2005/Jan/35
http://seclists.org/bugtraq/2005/Jan/37
http://seclists.org/bugtraq/2005/Jan/38

Solution :

Upgrade to IBM DB2 V8 Fix Pack 7a or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now