Squid SNMP Module asn_parse_header() Function Remote DoS

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is prone to a denial of service attack.

Description :

The remote Squid caching proxy, according to its version number, may
be vulnerable to a remote denial of service attack.

This flaw is caused due to an input validation error in the SNMP
module, and exploitation requires that Squid not only was built to
support it but also configured to use it.

An attacker can exploit this flaw to crash the server with a specially
crafted UDP packet.

Note that Nessus reports this vulnerability using only the version
number in Squid's banner, so this might be a false positive.

See also :

http://www.nessus.org/u?02d8db5a

Solution :

Upgrade to squid 2.5.STABLE7 / squid 3.0.STABLE7 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 15463 ()

Bugtraq ID: 11385

CVE ID: CVE-2004-0918