GLSA-200410-10 : gettext: Insecure temporary file handling

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200410-10
(gettext: Insecure temporary file handling)

gettext insecurely creates temporary files in world-writeable
directories with predictable names.

Impact :

A local attacker could create symbolic links in the temporary files
directory, pointing to a valid file somewhere on the filesystem. When
gettext is called, this would result in file access with the rights of
the user running the utility, which could be the root user.

Workaround :

There is no known workaround at this time.

See also :

http://www.securityfocus.com/advisories/7263
http://www.gentoo.org/security/en/glsa/glsa-200410-10.xml

Solution :

All gettext users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=sys-devel/gettext-0.14.1-r1'

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 15448 (gentoo_GLSA-200410-10.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0966