GLSA-200410-09 : LessTif: Integer and stack overflows in libXpm

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200410-09
(LessTif: Integer and stack overflows in libXpm)

Chris Evans has discovered various integer and stack overflows in libXpm,
which is shipped as a part of the X Window System. LessTif, an application
that includes this library, is susceptible to the same issues.

Impact :

A carefully-crafted XPM file could crash applications that are linked
against libXpm, such as LessTif, potentially allowing the execution of
arbitrary code with the privileges of the user running the application.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200409-34.xml
http://www.lesstif.org/ReleaseNotes.html
http://www.gentoo.org/security/en/glsa/glsa-200410-09.xml

Solution :

All LessTif users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=x11-libs/lesstif-0.93.97'
# emerge '>=x11-libs/lesstif-0.93.97'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 15447 (gentoo_GLSA-200410-09.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0687
CVE-2004-0688