GLSA-200409-31 : jabberd 1.x: Denial of Service vulnerability

This script is Copyright (C) 2004-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200409-31
(jabberd 1.x: Denial of Service vulnerability)

Jose Antonio Calvo found a defect in routines handling XML parsing of
incoming data. jabberd 1.x may crash upon reception of invalid data on
any socket connection on which XML is parsed.

Impact :

A remote attacker may send a specific sequence of bytes to an open
socket to crash the jabberd server, resulting in a Denial of Service.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All jabberd users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=net-im/jabberd-1.4.3-r4'
# emerge '>=net-im/jabberd-1.4.3-r4'

Risk factor :

Medium / CVSS Base Score : 5.0

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14799 (gentoo_GLSA-200409-31.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1378