GLSA-200409-13 : LHa: Multiple vulnerabilities

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200409-13
(LHa: Multiple vulnerabilities)

The command line argument as well as the archive parsing code of LHa lack
sufficient bounds checking. Furthermore, a shell meta character command
execution vulnerability exists in LHa, since it does no proper filtering on
directory names.

Impact :

Using a specially crafted command line argument or archive, an attacker can
cause a buffer overflow and could possibly run arbitrary code. The shell
meta character command execution could lead to the execution of arbitrary
commands by an attacker using directories containing shell meta characters
in their names.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200409-13.xml

Solution :

All LHa users should upgrade to the latest stable version:
# emerge sync
# emerge -pv '>=app-arch/lha-114i-r4'
# emerge '>=app-arch/lha-114i-r4'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14694 (gentoo_GLSA-200409-13.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0694
CVE-2004-0745
CVE-2004-0769
CVE-2004-0771