GLSA-200409-06 : eGroupWare: Multiple XSS vulnerabilities

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200409-06
(eGroupWare: Multiple XSS vulnerabilities)

Joxean Koret recently discovered multiple cross site scripting
vulnerabilities in various modules for the eGroupWare suite. This
includes the calendar, address book, messenger and ticket modules.

Impact :

These vulnerabilities give an attacker the ability to inject and
execute malicious script code, potentially compromising the victim's
browser.

Workaround :

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of eGroupWare.

See also :

https://sourceforge.net/forum/forum.php?forum_id=401807
http://www.securityfocus.com/archive/1/372603/2004-08-21/2004-08-27/0
http://www.gentoo.org/security/en/glsa/glsa-200409-06.xml

Solution :

All eGroupWare users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=www-apps/egroupware-1.0.00.004'
# emerge '>=www-apps/egroupware-1.0.00.004'

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14653 (gentoo_GLSA-200409-06.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1467