GLSA-200409-04 : Squid: Denial of service when using NTLM authentication

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200409-04
(Squid: Denial of service when using NTLM authentication)

Squid 2.5.x versions contain a bug in the functions ntlm_fetch_string()
and ntlm_get_string() which lack checking the int32_t offset 'o' for
negative values.

Impact :

A remote attacker could cause a denial of service situation by sending
certain malformed NTLMSSP packets if NTLM authentication is enabled.

Workaround :

Disable NTLM authentication by removing any 'auth_param ntlm program
...' directives from squid.conf or use ntlm_auth from Samba-3.x.

See also :

http://www.nessus.org/u?b945f310
http://www.gentoo.org/security/en/glsa/glsa-200409-04.xml

Solution :

All Squid users should upgrade to the latest stable version:
# emerge sync
# emerge -pv '>=net-www/squid-2.5.6-r2'
# emerge '>=net-www/squid-2.5.6-r2'

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14651 (gentoo_GLSA-200409-04.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0832