GLSA-200409-03 : Python 2.2: Buffer overflow in getaddrinfo()

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200409-03
(Python 2.2: Buffer overflow in getaddrinfo())

If IPV6 is disabled in Python 2.2, getaddrinfo() is not able to handle IPV6
DNS requests properly and a buffer overflow occurs.

Impact :

An attacker can execute arbitrary code as the user running python.

Workaround :

Users with IPV6 enabled are not affected by this vulnerability.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200409-03.xml

Solution :

All Python 2.2 users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=dev-lang/python-2.2.2'
# emerge '>=dev-lang/python-2.2.2'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14650 (gentoo_GLSA-200409-03.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0150