GLSA-200409-01 : vpopmail: Multiple vulnerabilities

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200409-01
(vpopmail: Multiple vulnerabilities)

vpopmail is vulnerable to several unspecified SQL injection exploits.
Furthermore when using Sybase as the backend database vpopmail is
vulnerable to a buffer overflow and format string exploit.

Impact :

These vulnerabilities could allow an attacker to execute code with the
permissions of the user running vpopmail.

Workaround :

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of vpopmail.

See also :

http://sourceforge.net/forum/forum.php?forum_id=400873
http://www.securityfocus.com/archive/1/371913/2004-08-15/2004-08-21/0
http://www.gentoo.org/security/en/glsa/glsa-200409-01.xml

Solution :

All vpopmail users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=net-mail/vpopmail-5.4.6'
# emerge '>=net-mail/vpopmail-5.4.6'

Risk factor :

High

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14648 (gentoo_GLSA-200409-01.nasl)

Bugtraq ID:

CVE ID: