GLSA-200408-20 : Qt: Image loader overflows

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200408-20
(Qt: Image loader overflows)

There are several unspecified bugs in the QImage class which may cause
crashes or allow execution of arbitrary code as the user running the Qt
application. These bugs affect the PNG, XPM, BMP, GIF and JPEG image
types.

Impact :

An attacker may exploit these bugs by causing a user to open a
carefully-constructed image file in any one of these formats. This may
be accomplished through e-mail attachments (if the user uses KMail), or
by simply placing a malformed image on a website and then convicing the
user to load the site in a Qt-based browser (such as Konqueror).

Workaround :

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of Qt.

See also :

http://www.mandrakesoft.com/security/advisories?name=MDKSA-2004:085
http://www.nessus.org/u?9aaee330
http://www.gentoo.org/security/en/glsa/glsa-200408-20.xml

Solution :

All Qt users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=x11-libs/qt-3.3.3'
# emerge '>=x11-libs/qt-3.3.3'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14576 (gentoo_GLSA-200408-20.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0691
CVE-2004-0692
CVE-2004-0693