GLSA-200408-18 : xine-lib: VCD MRL buffer overflow

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200408-18
(xine-lib: VCD MRL buffer overflow)

xine-lib contains a bug where it is possible to overflow the vcd://
input source identifier management buffer through carefully crafted
playlists.

Impact :

An attacker may construct a carefully-crafted playlist file which will
cause xine-lib to execute arbitrary code with the permissions of the
user. In order to conform with the generic naming standards of most
Unix-like systems, playlists can have extensions other than .asx (the
standard xine playlist format), and made to look like another file
(MP3, AVI, or MPEG for example). If an attacker crafts a playlist with
a valid header, they can insert a VCD playlist line that can cause a
buffer overflow and possible shellcode execution.

Workaround :

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of xine-lib.

See also :

http://www.open-security.org/advisories/6
http://www.gentoo.org/security/en/glsa/glsa-200408-18.xml

Solution :

All xine-lib users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=media-libs/xine-lib-1_rc5-r3'
# emerge '>=media-libs/xine-lib-1_rc5-r3'

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14574 (gentoo_GLSA-200408-18.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1475