GLSA-200408-12 : Gaim: MSN protocol parsing function buffer overflow

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200408-12
(Gaim: MSN protocol parsing function buffer overflow)

Sebastian Krahmer of the SuSE Security Team has discovered a remotely
exploitable buffer overflow vulnerability in the code handling MSN
protocol parsing.

Impact :

By sending a carefully-crafted message, an attacker may execute
arbitrary code with the permissions of the user running Gaim.

Workaround :

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of Gaim.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200408-12.xml

Solution :

All Gaim users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=net-im/gaim-0.81-r1'
# emerge '>=net-im/gaim-0.81-r1'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14568 (gentoo_GLSA-200408-12.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0500