GLSA-200408-09 : Roundup: Filesystem access vulnerability

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200408-09
(Roundup: Filesystem access vulnerability)

Improper handling of a specially crafted URL allows access to the
server's filesystem, which could contain sensitive information.

Impact :

An attacker could view files owned by the user running Roundup. This
will never be root however, as Roundup will not run as root.

Workaround :

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of Roundup.

See also :

http://secunia.com/advisories/11801/
http://www.gentoo.org/security/en/glsa/glsa-200408-09.xml

Solution :

All Roundup users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=www-apps/roundup-0.7.6'
# emerge '>=www-apps/roundup-0.7.6'

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14565 (gentoo_GLSA-200408-09.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1444