GLSA-200407-19 : Pavuk: Digest authentication helper buffer overflow

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200407-19
(Pavuk: Digest authentication helper buffer overflow)

Pavuk contains several buffer overflow vulnerabilities in the code
handling digest authentication.

Impact :

An attacker could cause a buffer overflow, leading to arbitrary code
execution with the rights of the user running Pavuk.

Workaround :

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of Pavuk.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200407-19.xml

Solution :

All Pavuk users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=net-misc/pavuk-0.9.28-r3'
# emerge '>=net-misc/pavuk-0.9.28-r3'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14552 (gentoo_GLSA-200407-19.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1437