GLSA-200407-09 : MoinMoin: Group ACL bypass

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200407-09
(MoinMoin: Group ACL bypass)

MoinMoin contains a bug in the code handling administrative group ACLs.
A user created with the same name as an administrative group gains the
privileges of the administrative group.

Impact :

If an administrative group called AdminGroup existed an attacker could
create a user called AdminGroup and gain the privileges of the group
AdminGroup. This could lead to unauthorized users gaining
administrative access.

Workaround :

For every administrative group with special privileges create a user
with the same name as the group.

See also :

http://www.nessus.org/u?b7f29b25
http://www.gentoo.org/security/en/glsa/glsa-200407-09.xml

Solution :

All users should upgrade to the latest available version of MoinMoin,
as follows:
# emerge sync
# emerge -pv '>=www-apps/moinmoin-1.2.2'
# emerge '>=www-apps/moinmoin-1.2.2'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14542 (gentoo_GLSA-200407-09.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0708