GLSA-200405-21 : Midnight Commander: Multiple vulnerabilities

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200405-21
(Midnight Commander: Multiple vulnerabilities)

Numerous security issues have been discovered in Midnight Commander,
including several buffer overflow vulnerabilities, multiple vulnerabilities
in the handling of temporary file and directory creation, and multiple
format string vulnerabilities.

Impact :

The buffer overflows and format string vulnerabilities may allow attackers
to cause a denial of service or execute arbitrary code with permissions of
the user running MC. The insecure creation of temporary files and
directories could lead to a privilege escalation, including root
privileges, for a local attacker.

Workaround :

There is no known workaround at this time. All users are advised to upgrade
to version 4.6.0-r7 or higher of Midnight Commander.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200405-21.xml

Solution :

All Midnight Commander users should upgrade to the latest stable version:
# emerge sync
# emerge -pv '>=app-misc/mc-4.6.0-r7
# emerge '>=app-misc/mc-4.6.0-r7'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14507 (gentoo_GLSA-200405-21.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0226
CVE-2004-0231
CVE-2004-0232