GLSA-200405-15 : cadaver heap-based buffer overflow

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200405-15
(cadaver heap-based buffer overflow)

Stefan Esser discovered a vulnerability in the code of the neon library
(see GLSA 200405-13). This library is also included in cadaver.

Impact :

When connected to a malicious WebDAV server, this vulnerability could allow
remote execution of arbitrary code with the rights of the user running
cadaver.

Workaround :

There is no known workaround at this time. All users are advised to upgrade
to the latest available version of cadaver.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200405-13.xml
http://www.gentoo.org/security/en/glsa/glsa-200405-15.xml

Solution :

All users of cadaver should upgrade to the latest stable version:
# emerge sync
# emerge -pv '>=net-misc/cadaver-0.22.2'
# emerge '>=net-misc/cadaver-0.22.2'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14501 (gentoo_GLSA-200405-15.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0398