GLSA-200405-01 : Multiple format string vulnerabilities in neon 0.24.4 and earlier

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200405-01
(Multiple format string vulnerabilities in neon 0.24.4 and earlier)

There are multiple format string vulnerabilities in libneon which may allow
a malicious WebDAV server to execute arbitrary code under the context of
the process using libneon.

Impact :

An attacker may be able to execute arbitrary code under the context of the
process using libneon.

Workaround :

A workaround is not currently known for this issue. All users are advised
to upgrade to the latest version of the affected package.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200405-01.xml

Solution :

Neon users should upgrade to version 0.24.5 or later:
# emerge sync
# emerge -pv '>=net-misc/neon-0.24.5'
# emerge '>=net-misc/neon-0.24.5'

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14487 (gentoo_GLSA-200405-01.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0179